Jump to content
xt:Commerce Community Forum

Search the Community

Showing results for tags 'zugriff'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • xt:Commerce - Professionelle eCommerce Shopsoftware
    • Fragen zur Software
    • xt:Commerce Plugins
    • xt:Commerce 4 Sprachen
    • xt:Commerce Online Handbuch
    • Häufige Fragen (FAQ)
    • Fragen zur Software (Pre Sale)
    • Anleitungen - Patches - Downloads
  • xt:Commerce Office - Shop & Warenwirtschaft
    • Allgemeine Fragen
  • xt:Commerce Allgemein
  • xt:Commerce 3 Shopsoftware Community Area (nur Lesen)
    • Allgemeine Diskussionen
    • Installation und Konfiguration
    • Shopbereich
    • Admininterface
    • Modul Entwicklung
    • Template System
    • xt:Commerce Schnittstellen ERP Systeme
    • PHP & MysQL Forum
    • HTML & CSS

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


ICQ


Yahoo


Jabber


Skype


Location


Interests


Biografie


Wohnort


Interessen


Beruf

Found 65 results

  1. Hallo, habe nun endlich geschaft ein Update auf die Version 4.1.10, nachdem ich die PHP Version auf 5.4 umgestellt habe. Habe aber keinen Zugriff mehr auf den Login im xtAdmin. Bin bei Alfahosting, muss ich noch was bei den Servereinstellungen vielleicht ändern? Bin für jeden Tip dankbar Pillle67
  2. Ich habe ein Problem mit dem Link auf eine Content-Seite: Es gibt eine Seite mit ID 7 "Information". Darunter gibt es eine Seite mit ID 8, "Details". Im Footer des Shops wird korrekt die Seite 7 verlinkt, auf Seite 7 gibts es ebenso korrekt ein Link auf Seite 8. Nun muss ich im Template ein Link direkt auf die Seite 8 setzen - und das gelingt mir nicht. Wie muss ich vorgehen?
  3. Hallo, ich baue gerade ein eigenes Plugin. Das passt soweit das ich normale Ausgaben erhalte. Die Ausgabeanweisungen stehen in einer sep. Datei "function...php" welche ich über einen Hook aufrufe. Also im HTML steht mein Hook: {hook key=print_myblabla} Und dieser Hook ruft dann meine Funktion auf <hook>print_myblabla</hook> <phpcode><![CDATA[ include _SRV_WEB_PLUGINS.'pk_blabla/functions/function.pk_blabla.php'; ]]> </phpcode> Die Funktion function.pk.blabla.php: <?php echo "Hallo Welt" ?> Jetzt würde ich in meiner PHP Funktionsdatei aber auch gerne auf Smartyvariablen wie z.B. den Produktnamen zugreifen wollen. Wie kann man das anstellen? Den Produktnamen selbst erhalte ich durch nen PHP Schnippsel in meiner HTML Datei einfach: {php} $php_variable = $this->get_template_vars('products_name'); echo $php_variable; {/php} Das muss doch auch in meiner ext. Funktion machbar sein?!
  4. Der cache Ordner lässt sich nicht mehr öffnen. Auch ein FTP backup ist deswegen nicht mehr möglich. Wenn man den Ordner anwählt läd und läd das Programm aber es passiert nichts weiter. Jemand eine Idee?
  5. Moin, ich erstelle zur Zeit eine iOS Shopping-App und bin jetzt beim Bestellvorgeng angelangt. Ich kann den Warenkorb mit Artikeln füllen. Wie kann ich von außen auf xtCommerce zugreifen und die Bestellung auslösen? Gibts da irgendwelche vorgefertigen Schnittstellen? Besten Dank schonmal
  6. Hallo, ich bin gerade dabei ein Pull-Down Menu für die Kategorien zu Programmieren. Ich habe mir dazu eine eigene Box gebastelt in der das Menu ausgegeben werden soll. Box: templates/xt_default/xtcore/boxes/box_categories_horizontal.html xtcore/boxes/categories_horizontal.php Aus der categories_horizontal.php lasse ich mir mit: $tpl_data = array('_categories'=> $category->getCategoryBox(0, true, 0),'_deepest_level_display'=>$category->deepest_level_display); die ersten beiden Ebenen meiner Navigation ausgeben. Dies funktioniert auch zuverlässig wie ich mit debug in der Templatedatei überprüfen kann und die zweite Ebene wird in 'sub' arrays abgelegt. 'sub' kann ich erfolgreich mit if abfragen ob mir bei entsprechung ein Pulldown ausgegeben werden soll - das klappt. Aber irgendwie komme ich jetzt nicht an die Werte innerhalb von 'sub'. <ul id="mp_menu" class="mp-menu"> {foreach name=aussen item=first_level from=$_categories} <li><a href="{$first_level.categories_link}" title="{$first_level.categories_heading_title}">{$first_level.categories_name}</a> {if $first_level.sub!=''} <ul> <li><span class="container_arrow" ><img src="/templates/xt_default/img/mp_menu/arrow_up_sub_container.png" /></span> </li> {foreach name=innen item=second_level from=$sub} <li><a href="{$second_level.categories_link}" title="{$second_level.categories_heading_title}">{$second_level.categories_name}</a> </li> {/foreach} </ul> {/if} </li> {/foreach} </ul> Wo liegt mein Fehler? Grüße
  7. Hallo an alle xt:Commerce Forum-Mitglieder, ich habe mich hier nun etwas länger umgeschaut und konnte für mein (womöglich nur ein kleines) Problem leider noch keine Lösung finden. Folgendes Szenario: Mein frisch installierter "xt:Commerce CE 4.0.14" liegt auf meinem Webspace im Root-Verzeichnis und ist durch meine Hauptdomain Domain.de ? Domains günstig registrieren ? Ihre Domain Suche und Verwaltung problemlos und wunderbar erreichbar. Es wird die unveränderte, original Shop-htaccess-Datei verwendet: # RewriteEngine on # RewriteRule !\.(js|ico|gif|jpg|png|css)$ index.php DirectoryIndex index.php RewriteEngine on RewriteCond %{REQUEST_URI} !^/media/ RewriteCond %{REQUEST_URI} !^/extAdmin/ RewriteCond %{REQUEST_URI} !^/skin/ RewriteCond %{REQUEST_URI} !^/js/ RewriteCond %{REQUEST_FILENAME} !-f RewriteCond %{REQUEST_FILENAME} !-d RewriteCond %{REQUEST_FILENAME} !-l RewriteRule .* index.php Zusätzlich habe ich eine Subdomain in Form von www.sub.domain.de, welche auf ein Unterverzeichnis weiterleitet, in der sich eine index.html befindet, die sich dann bei Aufruf der Subdomain ganz normal öffnet. Mein Problem besteht nun darin, dass die original Shop-htaccess-Datei den Zugriff auf die Subdomain verhindert. Immer wenn ich die Subdomain aufrufen möchte, bekomme ich eine Forbidden-Fehlermeldung. Wenn ich die original Shop-htaccess-Datei kurzzeitig lösche, ist die Subdomain wieder ganz normal erreichbar. Was genau müsste ich an der original Shop-htaccess-Datei verändern, damit auch meine Subdomain weiterhin erreichbar bleibt? Eine Löschung der original Shop-htaccess-Datei kommt für mich aus diversen Gründen nicht in Frage. Bitte die notwendige Änderung möglichst genau schildern, da ich bis auf etwas HTML-Verständnis gar keine Programmierkenntisse habe! Über Eure Zeit und Mühe in einen Lösungsvorschlag möchte ich mich bereits im Voraus ganz herzlich bedanken. Viele Grüße xtc4user
  8. Hallo, ich habe ein Problem, welches ich nicht allein lösen kann. Die Suchfunktion hat mich leider nicht weiter gebracht, ich habe vieles ausprobiert, aber leider keinen Erfolg gehabt. In der index.html wird an entsprechender Stelle über den Aufruf {box name=categories} die Kategoriebox integriert. In der Datei box_categories.html finde ich dann folgenden Code: <ul id="categorymenu"> {foreach name=aussen item=module_data from=$_categories} <li class="level{$module_data.level}{if $module_data.active} active{/if}"><a href="{$module_data.categories_link}" title="{$module_data.categories_heading_title}">{$module_data.categories_name}</a></li> {/foreach} </ul> Diesen Code möchte ich jetzt in der index.html leicht abgewandelt einbauen, um dort stets eine Linkliste zu den Level1-Kategorien zu integrieren: <ul> {foreach name=aussen item=module_data from=$_categories} {if $module_data.level == 1} <li><a href="{$module_data.categories_link}" title="{$module_data.categories_heading_title}">{$module_data.categories_name}</a></li> {/if} {/foreach} </ul> Wie ich nun festgestellt habe, funktioniert dies nicht, da die Variable $_categories in der index.html nicht verfügbar ist. Über das Handbuch und das Forum habe ich nun herausgefunden, dass man der index.html diese Variable an anderer Stelle übergeben muss. Leider habe ich nicht herausfinden können, in welcher Datei dies auf welche Weise geschehen muss. Ich wäre dankbar, wenn mich jemand auf die richtige Fährte leiten bzw. mir einen Link zu einem evtl. bereits bestehenden Beitrag geben könnte. S.W.
  9. Hallo, ich habe einen Artikel eingerichtet und diesen in den Warenkorb gelegt. Der Artikel wird auch in den Warenkorb gelegt. Möchte ich mir aber den Warenkorb anzeigen lassen, so komme ich wieder zurück zur Startseite. Klicke ich auf Kasse, dann gelange ich zu "Ihr Konto" - von da ab geht es nicht weiter. Könnt Ihr mir hier weiterhelfen? Der Shop liegt auf "exclusiveliving.de". mfg Reiner
  10. Hi, die Headline sagt es schon fast. Nach der Installation eines Moduls mit dem ich die URLs meines Shops entsprechend optimieren konnte, fand' ich (leider zu spät) heraus, dass ich seitdem keinen Zugriff mehr auf den Warenkorb habe. Produkte reinlegen und direkt zur Kasse gehen klappt wunderbar, jedoch kann ich beim Check des Warenkorbs nur eine leere Seite ausschließlich mit dem Hintergrundbild sehen. Das Modul habe ich von ShopStat © | Shop Statistik,Logfile Analyse,Web Controlling,User Tracking , das Modul ist dieses hier: ShopStat © | Shop Statistik,Logfile Analyse,Web Controlling,User Tracking (trägt den Namen "Suchmaschinenfreundliche URLs") Meine Version ist V. 3.0.4 SP2 bis SP2.1, habe dementsprechend auch das richtige Modul benutzt. Ist dieses Problem bereits bekannt oder habe ich einen Fehler bei der eigentlich sehr einfachen Installation gemacht? Danke im voraus für eure Hilfe.
  11. Hallo! Ich komme nicht mehr in den Admin wegen folgenden Fehlermeldungen: Warning: session_start() [function.session-start]: open(tmp/sess_8ef5731e166678308479e9b73d884f05, O_RDWR) failed: No such file or directory (2) in /.../includes/application_top.php on line 350 Warning: session_start() [function.session-start]: Cannot send session cache limiter - headers already sent (output started at /..includes/application_top.php:350) in /home/duftikus-com/htdocs/admin/includes/application_top.php on line 350 Warning: Cannot modify header information - headers already sent by (output started at /home/duftikus-com/htdocs/admin/includes/application_top.php:350) in /..includes/functions/general.php on line 130 Das tmp-Verzeichnis wurde im Hauptverzeichnis aber angelegt und die rechte auf 777 gesetzt Zeile 350 in der Appication_top.php } else { session_start(); $session_started = false; } // verify the ssl_session_id if the feature is enabled if ( ($request_type == 'SSL') && (SESSION_CHECK_SSL_SESSION_ID == 'True') && (ENABLE_SSL == true) && ($session_started == true) ) { $ssl_session_id = getenv('SSL_SESSION_ID'); if (!session_is_registered('SSL_SESSION_ID')) { $_SESSION['SESSION_SSL_ID'] = $ssl_session_id; } if ($_SESSION['SESSION_SSL_ID'] != $ssl_session_id) { session_destroy(); xtc_redirect(xtc_href_link(FILENAME_SSL_CHECK)); } } Wenn ich nun true eingebe funktioniert es auch nicht. Was Kann der fehler sein?
  12. Hallo, ich finde es ehrlich gesagt sehr unpraktisch das man wenn man ein Bestelltab eines Kunden öffnet keine Möglichkeit in der Bestellung hat direkt zum Kundenaccount zu gelangen? Für mich mal wieder nicht durchdacht denn oft ist es ja so das man die Bestellung öffnet und dann noch Daten im Kundenaccount ändern muss... immer einzeln den Kunden raussuchen ist viel zu zeitaufwändig? Gibt es hier ein Plugin das z.B. einen Button "Zum Kundenkonto" in die Bestellungen integriert? MfG
  13. Hallo, unsere Systemumgebung: Veyton Mandanten 4.0.12, auf Linux 1&1 Dedicated Server installiert. über die URL www.xyz.de gelange ich auf Shop A über die URL www.bbb.de gelange ich auf Shop B über die URL bbb.de (sprich ohne suffix www.) gelange ich wieder auf Shop A (den zuerst installierten). Kann mir jemand einen Tip geben wie ich auch ohne "www" auf den richtigen Shop gelange? Pinge ich beide an (mit und ohne www) sind die IPs identisch... Shop oder Serverroutingeinstellung? danke!
  14. Hallo, ich habe eine wichtige Content-Seite im Shop. Genauer gesagt geht es um die Startseite und die vergebene SEO Url. Im HTML Code dieser Seite wollte ich ein Script einbinden (<script language="php">{page name=xt_blog type=user};</script>, den Blog). War wohl irgendwo ein Fehlerteufel drin, da ich nun die Content-Seite im Shopadmin icht mehr aufrufen kann. Fehlermeldung kann ich posten, is allerdings geschätze 2 DINA4 Seiten lang. Wenn ich den Content einfach lösche und einen neuen anlege kann ich ja die SEO Url nicht mehr verwenden, was ziemlich schlecht wäre bei der Seite... Das Script funktioniert im Firefox problemlos, im IE bleibt es stumm und nichts passiert... Kann mir jemand helfen? Wie komme ich wieder auf den Content der Seite, nach möglichkeit über den Shopadmin? Danke!
  15. Hallo zusammen! Ich habe bei einem XT:C 3 Shop folgendes Problem: Wenn ich mit dem IE auf eine Kategorie klicke, dann lande ich direkt im Warenkorb mit der Meldung: Was aber z. B. geht ist folgendes: - im Hauptmenü auf "Neue Artikel" direkt auf einen Artikel zugreiffen - diesen dann in den Warenkorb legen - Anschliessend kann ich auf eine Kategorie klicken und es werden mir die Artikel angezeigt Wenn ich dann oben links auf "Startseite" klicke, dann sind plötzlich alle Artikel vom Warenkorb verschwunden und das Problem ist wieder da. Mit dem Firefox funktioniert alles wunderbar, nur beim IE gibts diese Probleme. Hat da vielleicht jemand einen Tipp für mich?
  16. Hi Leute, ist es möglich mit einer Veyton Web Version auf ein zentrales Ultimate zuzugreifen. So wie ein externer Client, der nur die Kategorien und die Artikel in seinem Shop wiedergibt (nicht hinein kopiert)aber die Verwaltung (Bestellabwicklung, Zahlungsabwicklung, Email usw.) auf seinem Client macht. Hier könnte er auch mit seiner Wawi rumwurschteln. Gruß Chris
  17. moin liebe xtc user. xtc 3 sp2 vorwort: ich sollte für meinem bekannten vor 3 jahren einen webshop installieren damit er seine produkte, neben ebay, verkaufen kann. nach kurzer zeit mussten wir feststellen das der shop sehr gut angenommen wird jetzt wird die seite auch noch im tv gezeigt (gelegentlich freitags ab 20:15 auf rtl2 in jedem werbeblock.... datum sag ich nicht ) frage: wir haben einen schnellen root server, aber in den werbepausen wird die webseite extrem langsam. in den "whois online" von xtc sind knapp 800 einträge. der server selber reagiert sehr schnell, aber warum ist die webseite so langsam (bis 6 sekunden pro seitenaufbau!!!) Ist XTC für sowas nicht ausgelegt? Habt ihr evtl ideen was ich in den einstellungen ändern könnte um die performance zu steigern? hoffentlich hab ich in das richtige forum geschrieben danke schon mal und regards aus der lüneburger heide patrick
  18. Hallo zusammen! Ich brauche dringend Hilfe. Ich habe mir heute die Testversion von CT:commerce erstellen lassen und nun stelle ich mit Entsetzen fest, das mein eigentlicher Shop nicht mehr geladen werden kann. Ich werde verrückt! Hängt das tatsächlich zusammen und wie kann ich das ganz schnell wieder rückgängig machen? Herzlichen Dank für eine super schnelle Antwort VG schussel (im wahrsten Sinne des Wortes)
  19. Hallo, nach dem serverumzug gehen ca. 200 Warungen und Fehler bei mir auf: Fatal error: Class 'PhpExt_Data_Store' not found in /var/www/web5/html/xtAdmin/dashboard.php on line 0 alles in Verbindung mit "PhpExt" Dann noch eine Fehlermeldung bei Update... Fatal error: Call to undefined function curl_init() in /var/www/web5/html/xtAdmin/versioncheck.php on line 0 Vielleicht hat jemand rat? Gruß
  20. Moin moin, habe folgendes Problem und bin für jede Hilfe dankbar. Für unseren Foto Shop, den wir gerade frisch und neu aufsetzen weil wir zu xt commerce wechseln, wollte ich alle Konfigurationen anpassen und war (soweit ich ich erinnern kann) bei den Session Einstellungen. Dort sollte ich die Angaben entweder auf "true" oder auf "false" setzen wie bei z.B.; Browser bei jedem Seitenaufruf prüfen - oder - IP Adresse bei jedem Seitenaufruf prüfen. Dort habe ich 2 Sachen verändert, auf speichern gedrückt und lande nun immer auf der Startseite. Wie kann ich das rückgängig machen? Vielen Dank im Voraus! Timm
  21. Hallo Community, ich habe vor kurzem am Cache rumgespielt weil es mich belastet, meinen Cache-Ordner 3x am Tag zu löschen, damit der Shop einigermaßen Geschwindigkeit hat. Jetzt bekomme ich immer die tolle Fehlermeldung im Shop: Warning: file(/home/www/meinepage.de/htdocs//cache/3b53b13f177209012a150e6ee9bffbb6.xtc) [function.file]: failed to open stream: No such file or directory in /home/www/meinepage.de/htdocs/inc/xtc_db_queryCached.inc.php on line 63 Warning: implode() [function.implode]: Bad arguments. in /home/www/meinepage.de/htdocs/inc/xtc_db_queryCached.inc.php on line 63 Warning: current() [function.current]: Passed variable is not an array or object in /home/www/meinepage.de/htdocs/inc/xtc_db_fetch_array.inc.php on line 28 Warning: next() [function.next]: Passed variable is not an array or object in /home/www/meinepage.de/htdocs/inc/xtc_db_fetch_array.inc.php on line 29 Von PHP habe ich keine Ahnung und weiß nicht was in den Zeilen falsch sein soll, da ich diese nicht verändert habe. Ich habe danach die alten Einstellungen wieder hergestellt. Das Problem bleibt nun ständig bestehen. Egal welche Einstellungen ich auch vornehme. Seltsam ist auch, dass wenn ich den Cache Ordner nicht angebe und die Cache-Option nicht aktiviere, sich dieser trotzdem füllt. Der DB-Cache ist aktiviert. In meinen Cache Ordner werden dann auch immer anstelle der XTC-Dateien seltsame .html Dateien geschrieben. Wenn ich diese lösche, funktioniert der Shop für kurze Zeit ohne Fehlermeldungen... Das nächste Problem habe ich mit der SSL Verschlüsselung. Ich habe beide configure.php Dateien angepasst. Wenn ich die SSL darin aktiviere, komme ich nicht mehr in meinen Admin-Bereich!? Komische Sache. Ich hoffe, dass jemand dieses Problem schon einmal hatte und mir nen kleinen Tipp geben kann. Vielen Dank Steffen Shop 3.04 Sp2.1
  22. Hi, wie kann ich auf das Category-Object zugreifen? Bzw. wie kann ich sonst herausfinden, ob ich mich in einer Category befidne oder nicht?
  23. Hallo an alle Wissenden, habe den xt:commerce webshop entsprechend der Anweisungen hochgeladen, (Testshop veyton_4012) die Lizenzdatei ins richtige verzeichnis kopiert, ioncube ins Verzeichnis kopiert (1und1) leider bekomme ich nur ZUGRIFF NICHT ERLAUBT error 403 zu sehen wo liegt der Fehler (außer bei mir)
  24. hi, ich hab noch nicht all zu viel ahnung von allem aber mein shop läuft schon seit na ganzen weile ganz gut und heute morgen bekam ich auf einmal folgende fehlermledung: woran könnte es liegen?? ich hab nix an der index-datei oder an den anderen dateien geändert. ==> www.pekairt.de/shop/index.php
  25. Hi, auf welche Informationen von xtc kann ich von außen zugreifen z.B. durch eigens entwickelte Applikationen auf Informationen aus dem Adminbereich zugreifen, natürlich vorrausgesetzt die Logindaten inklusive Adminrechte sind bekannt. Gibt es dafür schon eine vorgefertigte Schnittstelle? mfg Leonidus
×
×
  • Create New...