Jump to content
xt:Commerce Community Forum

Search the Community

Showing results for tags 'backend'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • xt:Commerce - Professionelle eCommerce Shopsoftware
    • Fragen zur Software
    • xt:Commerce Plugins
    • xt:Commerce 4 Sprachen
    • xt:Commerce Online Handbuch
    • Häufige Fragen (FAQ)
    • Fragen zur Software (Pre Sale)
    • Anleitungen - Patches - Downloads
  • xt:Commerce Office - Shop & Warenwirtschaft
    • Allgemeine Fragen
  • xt:Commerce Allgemein
  • xt:Commerce 3 Shopsoftware Community Area (nur Lesen)
    • Allgemeine Diskussionen
    • Installation und Konfiguration
    • Shopbereich
    • Admininterface
    • Modul Entwicklung
    • Template System
    • xt:Commerce Schnittstellen ERP Systeme
    • PHP & MysQL Forum
    • HTML & CSS

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


ICQ


Yahoo


Jabber


Skype


Location


Interests


Biografie


Wohnort


Interessen


Beruf

Found 175 results

  1. Hallo, ich wollte eine Kopie eines Shops anlegen (xt:commerce 4.2). Die Kopie basiert auf einer Entwicklerlizenz, diese wurde mir zugesendet und integriert. Das Frontend funktioniert und schaut gut aus. Allerdings macht mir das Backend Probleme. Ich kann mich einloggen, danach ist aber die Seite (das Backen) weiß/leer. Laut Quellcode der Seite, bricht die Seite im <head> ab. Was ich bereits getan habe: - alle Plugins in der Datenbank deaktiviert - Cache per FTP geleert - Cache deaktivert - in der config folgendes eingetragen: ini_set('display_errors', TRUE); error_reporting(E_ALL); -> Fehlermeldung: Warning: include_once(/var/www/web22/htdocs/stadtspiel-weimar.de/xtFramework/classes/class.cache.php): failed to open stream: No such file or directory in /var/www/web22/htdocs/stadtspiel-weimar.de/xtFramework/admin/main.php on line 69 Warning: include_once(): Failed opening '/var/www/web22/htdocs/stadtspiel-weimar.de/xtFramework/classes/class.cache.php' for inclusion (include_path='.:/opt/php56/share/pear:') in /var/www/web22/htdocs/stadtspiel-weimar.de/xtFramework/admin/main.php on line 69 -> die Datei class.cache.php existiert auch nicht im Orinialshop und leider finde ich auch online dazu keine nutzbare Datei. Desweiteren wurde an einer Stelle dazu gwesagt das man dies ignorieren könnte da es eine Altlast sei. Habt Ihr Tipps woran das liegen könnte? Viele Grüße
  2. Hallo, nach dem Update von 4.2.00 auf 5.0.07 werden die Preise im Backend nicht mehr wie vorher angezeigt: - Dashboard: 4 Stellen nach dem Komma (z.B. 9,9999 statt 10,00) - Artikel/Produkt: 6 Stellen nach dem Komma (z.B. 9,999999 statt 10,00) Wird ein Artikel mit "überlangem" Preis bearbeitet, also mit richtigem Preis gespeichert, so ist wieder alles richtig. Im Frontend ist alles in Ordnung. Weiß jemand, woran das liegt? Danke im Voraus!! Herzliche Grüße Nils
  3. Hallo, nächstes Problem : Zum Jahreswechsel hat sich der MWSt Satz in der Schweiz geändert. -> Mein Kunde hat den MWSt Satz im Backend geändert und anschließend alle Preise im Backend per Hand geändert. Folge : - bei registrierten Kunden wird die MWSt angezeigt - bei Neukunden wird keine MWSt angezeigt Im Backend wurde 10.5 CHF mit Standardsteuersatz hinterlegt. Neukunden bekommen diese 10.5 CHF plus zusätzliche MWSt. angezeigt. Der im Backend eingetragene Preis wird jetzt wohl als Nettopreise verwendet und Neukunden wird keine MWSt angezeigt. Ja, der MWSt Satz wurde für alle Zonen-IDs & Länder geändert. Vielen Dank für alle Ideen im voraus. Grüße, Michael PS :
  4. Hallo zusammen, wir sind vor kurzem auf einen leistungsstärkeren Server umgezogen. Seit dem Umzug funktionieren die Kategorien im Backend nicht mehr richtig. Das heisst, bei den einen Subkategorien steht zwar ein + davor, möchte man es aber aufklappen, funktioniert nichts. Bei den anderen funktioniert alles normal. Im Frontend wird alles normal angezeigt. Auch wenn ein Artikel bearbeitet wird, kann diesem die "verschwundenen" Kategorien zugeordnet werden. Die Servereinstellungen sind bis auf die PHP- Version (5.5) die gleichen, wir verwenden die Shopversion 4.2.00 mit den neusten Patches. Hat jemand eine Idee an was das liegen könnte? Viele Grüsse
  5. Hallo an alle, gibt es eine Möglichkeit Backend Zugang nur für Bestellungen von bestimmte Produkte zu haben? Ich wollte Zugang für einen Lieferant zur Verfügung stellen. Vielen Dank, Joao
  6. Hallo Leute ich habe eine Seite im Backend hinzugefügt die alle Daten aus einer Tabelle anzeigen soll. Leider wird, sobald ich die _get Methode überschreibe, nur noch eine Seite angezeigt und nicht mehr mehrere. Laut Handbuch sollte dies aber durch folgenden Eintrag in der _get Methode geschehen: // automatische Blättern-Funktion für Ihre Datensätze if (!$ID && !isset($this->sql_limit)) { $this->sql_limit = "0,25"; } Grüße
  7. Hi zusammen, ich habe in einem von mir betreuten Shop ein wiederkehrendes Problem - und zwar ist es so das die Redakteure erstmal ohne weitere Probleme arbeiten können und auch Artikel anlegen. Es ist aber so das ca. 1 mal die Stunde (so wurde mir berichtet) sich XT beim drücken auf Speichern "aufhängt". Will heißen, der Fortschrittsbalken fürs speichern kommt und es tut sich im Anschluss nichts mehr...die Seite muss neu geladen werden und der Datensatz ist verschwunden. Kann mir da wer weiterhelfen und mir ggf. Tips geben was man dagegen machen kann? Evtl irgendwelche PHP Memory Einstellungen oder sowas? XT Version ist die 4.2, mit Patches bis Dezember - das Problem selber zieht sich aber schon etwas länger seit der Version 4.0, ist nur durch verstärktes arbeiten am Shop jetzt häufiger anzutreffen. Vielen Dank und VG André
  8. Hallo Leute, ich habe einen neuen Tab im Backend geöffnet und führe nun per Hook (row_actions.php:actions) meinen eigenen Code aus. Nun würde ich gerne mit JQuery per ajax call ein PHP Script ausführen. Dieses ist unter "xt_my_test_plugin/hooks/dosom.php" zu finden Allerdings bekomme ich immer ein Error zurück und Firebug zeigt mir diesbezüglich folgenden Fehler an: 404 not found und The requested URL [Server pfad zu meinem Shop]/plugins/xt_my_test_plugin/hooks/dosom.php was not found on this server Mein Code: $urlplug = _SRV_WEBROOT.'plugins/xt_my_test_plugin/hooks/dosom.php'; echo '<h1 id="txttest" style="color: black">Hallo</h1>'; echo '<script type="text/javascript"> document.getElementById("txttest").innerHTML = "New text!"; $.ajax({ url: "'.$urlplug.'", type: "POST", success: function( response ) { console.log(response); $("#txttest").text("ok"); }, error: function(){ console.log("error is..."); $("#txttest").text("error"); } }); </script> Leider weiß ich nicht mit welchem anderen Pfad ich das Script ausführen soll. Ich freue mich über Antworten. Grüße
  9. Hallo Leute, ich versuche derzeit einen neuen Tab im Backend zu öffnen, wenn auf einen bestimmten Button gecklickt wird. Der Tab öffnet sich auch, allerdings wird die zu öffnende Klasse nicht geladen sondern es erscheint nur ein "Loading...". Mein Plugin heißt "xt_my_test_plugin" und die Klasse: "xt_my_test_plugin_action_translate" Der Code zum öffnen des Tabs: addTab('adminHandler.php?&plugin=xt_my_test_plugin&load_section=xt_my_test_plugin_action_translate', 'Test Tab Title');Hat vielleicht jemand von euch eine Idee wieso der Tab Inhalt nicht geladen wird? Grüße
  10. Hallo Leute, ist es möglich im Backend einen Menü Eintrag hinzuzufügen der beim auswählen ein PHP Script ausführt? Schön wäre es auch wenn ein Progress Balken angezeigt werden könnte. Hat vielleicht jemand von euch eine Idee wie ich da vorgehen kann? Grüße
  11. Hallo, ich bin schon länger auf der suche nach einer Möglichkeit, weiter Taps in der Produkt Bearbeitung (x-tab-panel-header x-unselectable) zu erstellen. Sprach Abhängigkeit ist nicht relevant. Es geht hier um die Taps Standard, Berechtigung, Master/Slave... usw. Ich will für Detail Angeben zu bestimmten Produkten Eingabefelder anlegen und da es sich um eine größere Menge Handelt, leidet die Übersicht im vorhanden Standard Tap darunter. Wäre super wenn mir jemand weiterhelfen könnte LG Flo
  12. Hallo, Ich habe einige Comboboxen / Selectboxen / Dropdowns. SObald ich etwas abgespeichert haben wir mir beim Editieren in der Comboboxen / Selectboxen / Dropdowns nur die ID ausgegeben. Das ist ziemlich Blöd wenn man mehrere Comboboxen / Selectboxen / Dropdowns in einem neuem Plugin benutzt. $header['material_type_id'] = array('text' => TEXT_MATERIALTYPE_NAME,'type' => 'dropdown','url'=>'DropdownData.php?get=material_type_id&plugin_code=dp_product_material');Versucht habe ich folgendes, dann wir mir der Wert auch ausgegeben, jedoch wird der Value im Hidden Feld auch überschrieben und der Eintrag wird durch die falsche SQL gelöscht. $header['material_type_id'] = array('text' => TEXT_MATERIALTYPE_NAME,'type' => 'dropdown','url'=>'DropdownData.php?get=material_type_id&plugin_code=dp_product_material', 'value' => $value);Gibt es weitere Parameter die übergeben werden können oder ähnliches? Vielleicht auch direkt in der Dropdown. $result[] = array('id' => $rs->fields['material_type_id'], 'name' => $rs->fields['materialtype_name'], 'desc' => $rs->fields['materialtype_name']);Gleiche gilt auch für die Artikelansicht mit Hersteller, etc...
  13. Guten Tag, ich habe folgendes Problem. Ich habe die Preise im Backend bei den jeweiligen Artikeln angebeben. z.B. 29.9 Dann stelle ich ein Steuerklasse 1 ( 19%) “Einstellungen -> Konfiguration -> Sonstiges” ist der Wert für “Brutto Admin” auf “true” Preis incl USt: [ x ]USt in Bestellung ausweisen: [ x ] Die Artikel werden im Shop mit 29.9 angezeigt, erst auf der letzten Seite des Checkouts kommen dann auf einmal +19% Mwst Dazu. Natürlich sollen die 29.9 bereits 19% erhalten, und nicht erst am Ende des Checkouts draufgerechnet werden,da ich in der Artikelansicht ja auch schreibe 29,9 inkl Mwst. Woran liegt dieses Problemchen? Grüße
  14. Hallo, wir haben in letzter Zeit vermehrt das Problem, dass sich entweder die komplette Bestellübersicht im Shop nicht anzeigen lässt, oder einzelne Bestellungen nicht geöffnet werden können. Das Problem ist das folgende: (2015-03-06 09:52:20) mysql error: [0: ] in EXECUTE("SELECT status_name from xt_system_status_description WHERE language_code = "de" AND status_id = ")[/CODE] Weiß jemand, wie der Fehler zustande kommt? Es liegt wohl am "status_id = " da dies so ja nicht geht, aber warum passiert das? Aktuell klappt es dann nur, wenn ich die betroffene Bestellung aus der Datenbank lösche, aber das ist ja keine Lösung.
  15. Hallo zusammen, leider komme ich derzeit nicht weiter. Seit dem Update auf 4.1.10 werden im Backend keine Bestellungen mehr angezeigt. Die Bestellungen ansich funktionieren, werden durchgeführt und auch entsprechend in die Wawi importiert. Im Backend wird jedoch kein Inhalt angezeigt.. ERROR-Log: PHP Fatal error: mysql error: [0: ] in EXECUTE("SELECT o.orders_source_external_id, os.source_name, CONCAT(acl.firstname, ' ', acl.lastname) AS order_edit_acl_user FROM xt_orders o LEFT OUTER JOIN xt_orders_source os ON o.source_id = os.source_id LEFT OUTER JOIN xt_acl_user acl ON o.order_edit_acl_user = acl.user_id WHERE o.orders_id = 116064")\n in SERVERPFAD/xtFramework/library/adodb5/adodb-errorhandler.inc.php on line 77, referer: http://shop.DOMAIN.de/xtAdmin/ejsadmin.php[/CODE] orders_id ist grundsätzlich die zuletzt durchgeführte Bestellung. Jemand eine Idee?
  16. Guten Morgen zusammen, dann will ich doch mal meine erste Anfrage stellen und hoffe auf hilfreiche Beiträge. Gestern habe ich das Update über den Update Wizard ausgeführt, was auch ohne Problem geklappt hat. Anfangs sah alles prima aus (im Frontend), ein Login brachte die Ernüchterung. die Kategorien werden nicht mehr angeziegt. Statt Dieser steht nun in der Navispalte links folgendes: TEXT-UNASIGNED-CATS Des Weiteren ist mir aufgefallen, dass zwischen den Oberpunkten EINSTELLUNGEN und SHOP-EINSTELLUNGEN nun zwei neue "Reiter" sind TEXT_CONFIG_PLUGIN und TEXT_CONFIG_SEO Einen Screenshot habe ich mal eingefügt. Jemand von euch eine Idee, woran das liegen könnte ? Ich würde mich freuen von euch zu lesen. Viele Grüße aus Hannover Oggi
  17. Hallo, gibt es eine Möglichkeit das Feld "Kommentar" im Backend unter >Kunden >Bestellungen editierbar zu machen? Gruss maldus
  18. Gibt es eine Möglichkeit beim Bearbeiten eines Artikels direkt die URL aus diesem Artikel aufzurufen? Ich möchte zur Kontrolle im Artikel diesen kurz anschauen ohne immer die URL kopieren zu müssen. Danke für die Info!
  19. Hallo, ich habe kürzlich auf MAC gewechselt und gucke mir gerade im Backend meine Artikel im XC Commerce 2.1 Shop an. Dabei habe ich feststellen müssen, das die Felder Artikelbeschreibung und Kurzbeschreibung beim öffnen der Seite im Backend ganz kurz angezeigt werden und dann völlig verschwinden. Im FireFox auf dem gleichen Rechner kann ich die beiden Felder sehen und bearbeiten. Kann wer helfen ??
  20. Hallo, es geht um die Produktliste in den Kategorien (Backend). Wenn ich beispielsweise 105 Produkte in einer Kategorie angelegt habe, kann ich die ersten Seiten problemlos aufrufen. Die letzte Seite wird aber nicht geladen. Bei der Seite mit den letzten 5 Produkte hängt sich das Backend auf. Es erscheint nur "Loading.." Bin für jeden Tipp dankbar.
  21. Hallo alle, bei der Grund/- Maßeinheitangabe im Backend wird bei mir in der 4.1.1 + PHP 5.3 immer noch kein Komma akzeptiert. Ist das normal? Bei der Preiseingabe jedoch schon. Vom Import an den Shop ganz zu schweigen. Gibt es eine Möglichkeit im PHP das Komma in einen Punkt zu ersetzen?
  22. Hallo, weiß jemand von euch ob man im Backend eine 301-Weiterleitung machen kann? Bei uns ändern sich manchmal Artikel und ich möchte nicht jedesmal unsere Agentur bemühen. Vielen Dank!
  23. Hallo, ich habe jetzt ein Update auf die 4.1.10 gemacht. jetzt werden aber keine Bestellungen mehr im Backend angezeigt, weiss jemand an was das liegen kann? Grüße
  24. ich werd wahnsinnig mit veyton, alles lief perfekt. plötzlich wird im backen-bestellungen-bestellung bearbeiten nur noch die hälfte angezeigt. d.h. dass ich keine Adresse(n) und Artikel sehe. nur das "Fenster" hinzugefügt-bestellstatus.... und das Fenster Bestellstatus ändern wird angezeigt wie kann das denn passieren bzw weiss jemand rat wie das wieder zu ändern ist. besten dank
  25. Hallo, wir haben auf einmal das Problem das im Backend Veyton 4.0.15 keine Bestellungen mehr angezeigt werden, auch mehrfaches "Neu laden" bringt nichts. Provider 1&1 sagt bei Ihnen läuft alles tip top!! In der Kundenliste im Backend direkt auf Bestellung geht, dann wird diese angezeigt, nur halt nicht die gesamte Liste aller Bestellungen. Haben es auch schon mit anderem Browser versucht keine Veränderung. Auch bei den Kundendaten muß auf "Neu laden" geklickt werden damit diese angezeigt werden, Ladevorgang dauert halt einen Augenblick. Frontend läuft. Kategorien und Artikel können bearbeitet werden, hängt nur an den Bestellungen, oder gibts da eine Limitierung? 1993 Bestellungen. Provider hatte die htaccess als eventuelle Quelle angesehen, weil hier - AddType x-mapp-php5 .php - - AddHandler x-mapp-php5 .php - drin steht. Wir haben´s dann mal auf php5.4 php geändert, da lief der Shop nicht mehr. Einer ein Idee, was da nicht rundläuft? Danke Gruß Tom
×
×
  • Create New...