Sign in to follow this  
Followers 0

Probleme mit ionCube Update


19 posts in this topic

Posted (edited) · Report post

Hallo erst einmal,

ich bitte schon einmal von vornherein um Entschuldigung fals ich im falschen Themenbereich schreibe oder es genau das Thema schon gibt.

Das ist mein erster Beitrag und ich komme einfach nicht weiter.

Ich habe folgendes Problem:

Ich habe einen V-Server auf Windows-Basis (Windows Server 2008 SP2 + Plesk 10.2) von Strato, auf dem ich meinen Shop installieren wollte.

Ich habe mir die Community Edition von xt:Commerce heruntergeladen und wollte diesen eben installieren. Ich habe das Problem das ich auf der folgenden Seite *gelöscht* nur ein weises Bild bekomme bzw. die leichte Schraffur im Hintergrund. Naja habe dann hier nachgelesen das mir der ionCube Loader fehlt.

Diesen habe ich mir dann runtergeladen und installiert, was mir zumindest hier gesagt wird. *gelöscht*

Habe dannach auch schon meinen Server rebootet, aber dennoch bekomme ich nur die weise Seite und kann meinen Shop somit nicht installieren,

da auf der loader Seite welche mir sagt das es bereits installiert ist, gesagt wird das ich nicht die akutellste Version habe, wollte ich eben ein Update machen aber wenn ich die .dll überschreibe mit der im Link befindlichen Datei passiert mal gar nichts und ja, da wollte ich Fragen ob mir vielleicht jemand helfen kann.

Hoffe Ihr habt Verständniss für diese (wahrscheinliche) Amateurfrage aber ich weis nicht mehr weiter, kA vielleicht liegts auch an der Uhrzeit. :confused: Jedoch würde ich mich sehr über Hilfe freuen.

Danke schon einmal im Voraus.

LG

Edited by green-life-computer

Share this post


Link to post
Share on other sites

Posted · Report post

Evanzo halt:)

Nein, Spass beiseite, du musst den IIS noch richtig konfigurieren, dann läufts auch, wird aber aufgrund Plesk nicht gerade ein Zuckerschlecken;)

Meine Meinung: tu dir selbst den Gefallen und wechsel auf ein passendes Hostingpaket, da ich aus deinem Post lese dass du wenig bis keine Ahnung von Windowsservern hast (.dll überschrieben). Bei Windows macht man kein Update indem man einfach Dateien überschreibt, schon gar nicht bei Servern:eek:

Share this post


Link to post
Share on other sites

Posted · Report post

Hallo,

danke erst einmal für deine Antwort, dann guck ich nochmal in die IIS Einstellungen.

Habe ja nicht gesagt das ich im Windows System eine .dll überschrieben habe sondern nach Anweisung die .dll im ioncube ordner die er ja dann laut beschreibung Updaten sollte.

Was er aber nicht tut...das war das Problem.

=)

LG

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

*gelöscht, weils Quark war*

Edited by Fry

Share this post


Link to post
Share on other sites

Posted · Report post

Hallo noch mal,

also kann mir keiner so recht helfen wie es Aussieht, naja dennoch danke...dann habe ich wenigstens schon einmal einen Anlaufpunkt... ISS *lacht*

Wenn einer noch etwas weis wie ich es angehen kann dann wäre es cool wenn er sich hier kurz melden würde.

Danke schon einmal

LG

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

Die ISS ist eine Raumstation *mitlacht*

Wie sehen die Einstellungen denn generell aus? Da ich bis dato weder Windows noch Plesk auf Servern eingesetzt habe müsste schon ein kleiner Anhaltspunkt dazu her, ansonsten kann dir niemand mit deinen spärlichen Informationen, die du angibst, helfen;)

Wie sehen z.B. deine DNS-Einträge für die Domain bei Evanzo aus? Wie sehen diese bei Plesk aus? Verarbeitet Plesk die auch korrekt? Akzeptiert Win diese von Plesk bereitgestellten einträge? Spasseshalber mal ein non-Ioncube-system unetr der slben (Sub)Domain aufgesetzt?

Glaskugel?

Die dicke Edith sagt: deine php.info sagt mir dass du leider immer noch kein IonCube installiert hast:)

Edited by Fry

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

Ja sorry habe mich verschrieben ich meinte Natürlich IIS,

und soweit ich weis habe ich doch ioncube installiert.

siehe *gelöscht*

wenn ich das richtig sehe ist die version ionCube PHP Loader v4.0.7 am laufen.

aber ich lasse mich gerne belehren.

Also die DNS Einträge zwischen Evanzo und Plesk müssen identisch sein, richtig?

Wie kann ich denn feststellen ob Windows die von Plesk bereitgestellten Einträge akzeptiert?

Und was für ein non-ioncube system gibt es denn so? *lacht*

Danke für die Hilfe schon mal =)

Edited by green-life-computer

Share this post


Link to post
Share on other sites

Posted · Report post

Hmmm, ohne jetzt ins Fettnäpfchen treten zu wollen: bitte dringendst den ersten Post von mir hier lesen, speziell meine Meinung dazu.

Du versuchst Ioncube einzubinden auf Basis wie man es bei Webspace macht, dabei hast du einen Server mit Vollzugriff, du verlinkst eine php.info die du selbst hochgeladen hast obwohl dir dein Server eine zur Verfügung stellt, du bist http://root-und-kein-plan.ath.cx/

(Ist zwar auf *nix gemünzt, trifft Windows aber genauso)

Dein Server will dieses und du bietest ihm das, und er kann damit nichts anfangen und sagt es dir sogar:

zend_extension_ts="C:\Program Files\Parallels\Plesk\Additional\PleskPHP5\ext\ioncube_loader_win_5.2.dll"

;;; *UNRECOGNISED INI FILE at C:\Inetpub\vhosts\green-life-computer.de\httpdocs\ioncube\php.ini* ;;;

zend_extension=/Programme/Parallels/Plesk/Additional/PleskPHP5/ext/ioncube_loader_win_5.2.dll

Lerne Server zu administrieren, den Unterschied zu Webspace vs. Server zu kennen und Plesk (und Windows) zu sagen was zu tun ist, oder wechsel schleunigst auf ein Webspace, wo dir der Provider die Arbeiten abnimmt.

Ich will nur hoffen dass dein Nick kein Programm wird:eek:

Edith sagt: ein non-Ioncube-System wäre z.B. 3.04SP2.1;)

Share this post


Link to post
Share on other sites

Posted · Report post

Hm naja danke für die nette Hilfe, jeder hat irgendwo mal klein angefangen und ich stehe gerade am Anfang. Dachte ein Forum ist dafür da das man Hilfe bekommen kann aber okay.

Nur das ich nicht bei jeden kleinen Problemchen zu meinem Anbieter rennen will so das er mir das einstellt und ich dann immer noch nicht so richtig weis wie was funktioniert.

Werde nun zusehen das ich selbst damit klar komme, danke nochmals für die Hilfe.

LG

Share this post


Link to post
Share on other sites

Posted · Report post

Bei einem Root Server muss man immer beachten das man darauf einen Shop hostet mit under anderem Datenschutzrelevanten Daten von Kunden.

Wird nun ein solcher Root Server nicht professionell administriert kann schnell durch eine falsche konfiguration oder ein nicht gepatchte lücke ein Einbruch stattfinden und als Betreiber kann man hier durchaus zur Verantwortung gezogen werden.

Von daher, Root Server nur wenn man auch über das notwendige Know-How verfügt, ansonsten Managed Hosting!

Share this post


Link to post
Share on other sites

Posted · Report post

Danke für den Hinweis aber ich habe es eben vor mir das alles anzueignen und wollte nur vorübergehend schon mal meinen Shop installieren um Testen zu können und da ich das nur Nebenher betreiben will und auch nicht all zu viel Geld dafür ausgeben will wollte ich keinen überteuerten Managed Server mieten den ich eh nicht ausnutze.

Zudem ich mich an folgende Anleitung gehalten habe und es darauf hin nicht funktioniert hat. Deshalb habe ich hier nachgefragt woran das liegen mag, soweit was ich bis jetzt gelesen habe leitet alles auf diese Seite gebracht hat:

PHP Encoder, protection, installer and performance tools from ionCube: Loader Installation

Ist das die Falsche Art und Weise es zu installieren?

Denn jeder sagt das es einfach ist zu installieren?

Welche php.ini muss ich eigentlich genau bearbeiten?

Die unter C:\Windows oder die beiden im Plesk Verzeichnis, das bekommt man auch nirgends gesagt? Oder muss man alle auf die gleiche Datei zugreifen etc. alles das wollte ich wissen und nicht das ich dafür nur zu unerfahren bin.

Wenn ich es nicht wäre würde ich ja auch nicht nachfragen, oder? :confused:

LG

Share this post


Link to post
Share on other sites

Posted · Report post

Ist das die falsche Art und Weise es zu installieren?

Ja, denn du hast einen Server!

Denn jeder sagt das es einfach ist zu installieren?

Die haben ja auch keinen Server, sondern Webspace:p

Welche php.ini muss ich eigentlich genau bearbeiten? Die unter C:\Windows oder die beiden im Plesk Verzeichnis, das bekommt man auch nirgends gesagt?

Die grundlegendn Basics muss ein verantwortungsbewusster Serveradmin von selbst wissen, die Antwort war aber schon zitiert:

zend_extension_ts="C:\Program Files\Parallels\Plesk\Additional\PleskPHP5\ext\ion cube_loader_win_5.2.dll"

;;; *UNRECOGNISED INI FILE at C:\Inetpub\vhosts\green-life-computer.de\httpdocs\ioncube\php.ini* ;;;

zend_extension=/Programme/Parallels/Plesk/Additional/PleskPHP5/ext/ioncube_loader_win_5.2.dll

Mehr gibt es nicht zu sagen, die Sachen sind einleuchtend wie eine 100Watt Glühbirne, ausser danach noch den Server/Apachen neu zu starten.

Share this post


Link to post
Share on other sites

Posted · Report post

Hm naja danke, dann wird es wohl erstmal nichts mit meinem Shop,

aber eins versteh ich nicht, du meintest das das keine Anleitung ist um auf nem Server zu installieren, richtig?

Dann weis ich nicht wieso ganz unten in der Installationsanleitung folgendes steht:

Installation on a Windows Server

You need a Loader called

ioncube_loader_win_<php flavour>.dll

<php flavour> will be 4.1, 4.2 or 4.3 - i.e the first 2 digits of your PHP version.

Edit your php.ini file and add:

zend_extension_ts = "<drive>:\<path>\ioncube_loader_win_<php flavour>.dll"

where <drive> and <path> locate the Loader, and <php flavour> is whatever the correct value is for your system. If there are other zend_extension entries in the php.ini file place this new entry before the existing entries.

e.g.

zend_extension_ts = c:\WINNT\ioncube_loader_win_4.3.dll

Naja aber danke nochmal, wünsche noch einen schönen Abend erstmal.

LG

Share this post


Link to post
Share on other sites

Posted · Report post

Genau, das steht in der Anleitung von Ioncube, und dann arbeitest du weiter mit dem anlegen einer eigenen php.ini, und ab da fangen deine Fehler und Verständnisse grob gesagt an, du haust das eine immer mit dem anderen zusammen und durcheinander:rolleyes:

Share this post


Link to post
Share on other sites

Posted · Report post

Ich hab nichts mit einer eigenen php.ini gemacht sondern nur die bestehenden bearbeitet und ich habe seit Server installation drei php.ini Datein aufm Server.

Ich habe lediglich das gemach was da unten in der Installationsanleitung steht,

und in meiner info.php steht auch das ich schon die Version 4.x.x benutze. Welche genau weis ich jetzt nicht xP

Share this post


Link to post
Share on other sites

Posted · Report post

Und woher kommt die php.ini unter

C:\Inetpub\vhosts\green-life-computer.de\httpdocs\ioncube\php.ini

her? Von der Installation wie es für Webspace vorgegeben ist!

Wenn du Ioncube richtig eingebunden hättest dann wäre dieses Verzeichnis überhaupt nicht existent...

Ich gebs auf:)

Share this post


Link to post
Share on other sites

Posted · Report post

Die habe ich nicht erstellt sondern nur eben dort zwischengespeichert so das im falle eines Fehlers das wieder zurückgeschoben werden kann.

Aber da du es ja aufgibst, danke ich dir nochmals.

Kompetente Forumhilfe, respekt. (nicht auf alle User bezogen)

Anstatt einfach mal zu erklären wie es angegangen werden muss, so das es dann funktioniert. Auch mal davon abgesehen das es viele User gibt die aus den gleichen Gründen sich einen Server mieten statt einen Webspace.

Share this post


Link to post
Share on other sites

Posted · Report post

Respekt vor so viel Beratungs- und Lernresistenz!

Ohne dass du die grundlegenden Basics beherrscht kann man dir nicht helfen, denn wenn doch dann willst du immer das Wasser und das Eis zusammen in den Ofen stellen und wunderst dich, warum danach beides weg ist:(

Am besten du setzt den Server nochmals neu auf (da ich nicht weiss wo schon überall herumgefuhrwerkt wurde), stopfst die Sicherheitslücken, die bei den Stratoimages standartmässig so gross wie Scheunentore sind, und dann installierst du Ioncube exact dort, wo Plesk ihn haben will, nirgends wo anders, und auch nirgends eine php.ini "zwischenlagern", sonst stehst du wieder dort wo du jetzt auch stehst.

Wie das genau geht, steht bis ins kleinste Detail hier in diesem Thread!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0