Jump to content
xt:Commerce Community Forum
Sign in to follow this  
dimoncss

PHP MyAdmin fehler drin

Recommended Posts

ich habe im PHPmyAdmin diese Fehler:

Die Erweiterung mcrypt fehlt. Bitte die PHP-Konfiguration überprüfen.[/CODE]

Der phpMyAdmin-Konfigurationsspeicher ist nicht vollständig konfiguriert, einige erweiterte Funktionen wurden deaktiviert. Klicken Sie hier, um herauszufinden warum.

[PHP]$cfg['Servers'][$i]['pmadb'] ... fehlerhaft [ Dokumentation ]
$cfg['Servers'][$i]['relation'] ... fehlerhaft [ Dokumentation ]
Allgemeine Verknüpfungsfunktionen: Deaktiviert

$cfg['Servers'][$i]['table_info'] ... fehlerhaft [ Dokumentation ]
Anzeige verknüpfter Daten: Deaktiviert

$cfg['Servers'][$i]['table_coords'] ... fehlerhaft [ Dokumentation ]
$cfg['Servers'][$i]['pdf_pages'] ... fehlerhaft [ Dokumentation ]
Erzeugen von PDFs: Deaktiviert

$cfg['Servers'][$i]['column_info'] ... fehlerhaft [ Dokumentation ]
Darstellung von Spaltenkommentaren: Deaktiviert
Darstellungsumwandlung: Deaktiviert

$cfg['Servers'][$i]['bookmarktable'] ... fehlerhaft [ Dokumentation ]
Gespeicherte SQL-Abfrage: Deaktiviert

$cfg['Servers'][$i]['history'] ... fehlerhaft [ Dokumentation ]
SQL-Verlaufsprotokoll: Deaktiviert

$cfg['Servers'][$i]['designer_coords'] ... fehlerhaft [ Dokumentation ]
Designer: Deaktiviert

$cfg['Servers'][$i]['recent'] ... fehlerhaft [ Dokumentation ]
Gespeicherte kürzlich verwendete Tabellen: Deaktiviert

$cfg['Servers'][$i]['table_uiprefs'] ... fehlerhaft [ Dokumentation ]
Gespeicherte Tabellen-Darstellungs-Optionen: Deaktiviert

$cfg['Servers'][$i]['tracking'] ... fehlerhaft [ Dokumentation ]
Nachverfolgung: Deaktiviert

$cfg['Servers'][$i]['userconfig'] ... fehlerhaft [ Dokumentation ]
Benutzereinstellungen: Deaktiviert

[/PHP]

Share this post


Link to post
Share on other sites

Moin,

Im Prinzip sind das keine Fehler sondern Hinweise.

Das erste bedeutet, dass dir ein PHP-Modul fehlt. Mcrypt ist ein PHP-Modul, welches Methoden zur Ver- und Entschlüsselung von Daten zur verfügung stellt.

Das zweite sind Erweiterungseinstellungen von phpMyAdmin die nicht zwingend notwendig sind. Lies dazu einfach mal im Wiki von phpMyAdmin nach.

Ich hoffe ich konnte helfen.

LG

Share this post


Link to post
Share on other sites

kriege auch diese Fehlermeldung

mysql error: [1048: Column 'products_name' cannot be null] in EXECUTE("INSERT INTO xt_orders_products ( ORDERS_ID, PRODUCTS_ID, PRODUCTS_MODEL, PRODUCTS_NAME, PRODUCTS_PRICE, PRODUCTS_DISCOUNT, PRODUCTS_TAX, PRODUCTS_TAX_CLASS, PRODUCTS_QUANTITY, PRODUCTS_DATA, ALLOW_TAX, PRODUCTS_SHIPPING_TIME ) VALUES ( 290, 621, null, null, 0, null, null, null, 1, null, 1, null )")[/PHP]

Share this post


Link to post
Share on other sites

Moin,

auch das erklärt sich eigentlich von selbst.

Hier wurde versucht ein Produkt anzulegen, ohne einen Produktnamen vergeben zu haben. Die Tabelle xt_products ist so eingestelltk, dass sie NULL-Werte für den Produktnamen nicht zulässt und den Fehler produziert.

LG

Share this post


Link to post
Share on other sites

danke für feedback, das problem ist schon gelöst. wie im anderen Post geschrieben, die Tracking Pixel Tag hat ein Fehler enthalten im Checkout_success.php dadürch wurde dieser Fehler verursacht.

Share this post


Link to post
Share on other sites

hallo dimoncss

kriege auch diese Fehlermeldung

mysql error: [1048: Column 'products_name' cannot be null] in EXECUTE("INSERT INTO xt_orders_products ( ORDERS_ID, PRODUCTS_ID, PRODUCTS_MODEL, PRODUCTS_NAME, PRODUCTS_PRICE, PRODUCTS_DISCOUNT, PRODUCTS_TAX, PRODUCTS_TAX_CLASS, PRODUCTS_QUANTITY, PRODUCTS_DATA, ALLOW_TAX, PRODUCTS_SHIPPING_TIME ...[/PHP]

das ist bei mir seit einiger Zeit auch der Fall.

Wie hast du es wegbekommen? Das kann doch nicht am Tracking Pixel Tag gelegen haben?! Bzw wie hast du die checkout.success.php abgeändert?

@Sentor77: Hier wurde doch nicht versucht ein Artikel anzulegen... Eher wird versucht ein Artikel ohne eingetragenen Namen zu bestellen. Das Statement wird nicht natürlich nicht ausgeführt und somit kommt es zu einer Bestellung ohne Position.

Jedoch gibt es bei mir keine Artikel ohne Namen.

Im ganzen Forum gibt es keine Lösung (ich hab woanders auch schon gepostet), die Frage taucht aber seit ca. 2009 immer wieder mal auf.

Share this post


Link to post
Share on other sites

1) ist das ein unterforum von Version 3

2) support gibt es über den helpdesk (forum ist nicht supported)

3) zwischen kritik und schädigenden aussagen gibt es einen unterschied.

Bietrag geschlossen.

Edited by mzanier

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  

×
×
  • Create New...